Vous souhaitez développer une application en Windev qui permet d'envoyer des SMS ? Consultez nos exemples de codes pour chacune des fonctionnalités disponibles depuis notre API SMS.

				      			sENVOYERSMSPRO_LOGIN est une chaîne
								sENVOYERSMSPRO_LOGIN=""
								
								sENVOYERSMSPRO_PASSWORD est une chaîne
								sENVOYERSMSPRO_PASSWORD=""
								
								sUrlRequete est une chaîne
								sUrlRequete ="https://www.envoyersmspro.com/api/message/send"
								
								// Paramètres Post
								sParametrePost est une chaîne
								sParametrePost=ChaîneConstruit("text=%1&recipients=%2&sendername=%3","Ceci est un test via l'API d'Envoyer SMS Pro depuis un script WINDEV","33600000000","SOCIETE") 
								
								// Requête
								SI HTTPRequête(sUrlRequete, "", "",sParametrePost, "application/x-www-form-urlencoded",sENVOYERSMSPRO_LOGIN,sENVOYERSMSPRO_PASSWORD)=Vrai ALORS
									sXMLEXPRESS est un xmlDocument
									sXMLEXPRESS = XMLOuvre(HTTPDonneRésultat(httpRésultat),depuisChaîne)
									SI sXMLEXPRESS.envoyersmspro.status = "success" ALORS
										Info( "Votre message a bien été envoyé : " , "Le messageid : " + sXMLEXPRESS.envoyersmspro.message.message_id + RC + "Nombre de SMS envoyés : " + sXMLEXPRESS.envoyersmspro.message.sms_sent + RC + "Nombre de SMS restant : " + sXMLEXPRESS.envoyersmspro.message.sms_remaining)
									SINON
										Info("Votre message n'a pas pu être envoyé : ","request : " + sXMLEXPRESS.envoyersmspro.error.request, "error_id : " + sXMLEXPRESS.envoyersmspro.error.error_id, "error_message : " +  sXMLEXPRESS.envoyersmspro.error.error_message)
									FIN		
								SINON
									Erreur(ErreurInfo())
								FIN				      			
				      			sENVOYERSMSPRO_LOGIN est une chaîne
								sENVOYERSMSPRO_LOGIN=""
								
								sENVOYERSMSPRO_PASSWORD est une chaîne
								sENVOYERSMSPRO_PASSWORD=""
								
								sUrlRequete est une chaîne
								sUrlRequete ="https://www.envoyersmspro.com/api/message/stats"
								
								// Paramètres Post
								sParametrePost est une chaîne
								sParametrePost=ChaîneConstruit("messageid=%1","0") 
								
								// Requête
								SI HTTPRequête(sUrlRequete, "", "",sParametrePost, "application/x-www-form-urlencoded",sENVOYERSMSPRO_LOGIN,sENVOYERSMSPRO_PASSWORD)=Vrai ALORS
									sXMLEXPRESS est un xmlDocument
									sXMLEXPRESS = XMLOuvre(HTTPDonneRésultat(httpRésultat),depuisChaîne)
									SI sXMLEXPRESS.envoyersmspro.status = "success" ALORS
										
										sFirstLine est une chaîne
										sFirstLine = "Statistiques groupées : "
										
										sFirstLine += RC + RC + sXMLEXPRESS.envoyersmspro.stats.number_status_1 + " SMS délivré(s)"
										sFirstLine += RC + sXMLEXPRESS.envoyersmspro.stats.number_status_2 + " SMS non délivré(s)"
										sFirstLine += RC + sXMLEXPRESS.envoyersmspro.stats.number_status_3 + " SMS en attente chez l'opérateur"
										sFirstLine += RC + sXMLEXPRESS.envoyersmspro.stats.number_status_4 + " SMS en cours de traitement"
										sFirstLine += RC + sXMLEXPRESS.envoyersmspro.stats.number_status_5 + " numéro(s)  en STOP SMS"
										
										XMLDocument("tmpXML",HTTPDonneRésultat(httpRésultat))
										
										sSecondLine est une chaîne
										sSecondLine = "Statistiques détaillées : " + RC
										
										sCurrentDate est une chaîne
										
										XMLRecherche("tmpXML", "recipient", XMLBalise ,XMLExact)
										TANTQUE XMLTrouve("tmpXML") = Vrai
											XMLFils("tmpXML")
											
											sSecondLine += RC + "Le numéro  " + XMLDonnée("tmpXML")
											XMLSuivant("tmpXML")
											sCurrentDate = XMLDonnée("tmpXML")
											XMLSuivant("tmpXML")
											
											SI XMLDonnée("tmpXML") = 1 ALORS
												sSecondLine += " a reçu le SMS à " + sCurrentDate
											SINON SI XMLDonnée("tmpXML") = 2 ALORS
												sSecondLine += " n' a pas reçu le SMS"
											SINON SI XMLDonnée("tmpXML") = 3 ALORS
												sSecondLine += " est en attente de réception (en attente chez l'opérateur)"
											SINON SI XMLDonnée("tmpXML") = 4 ALORS
												sSecondLine += " est en attente de réception (en cours de traitement)"
											SINON SI XMLDonnée("tmpXML") = 5 ALORS
												sSecondLine += " est en STOP SMS"
											FIN
											XMLParent("tmpXML")
											XMLSuivant("tmpXML")
										FIN
										
										XMLTermine("tmpXML")
										
										Info(sFirstLine,RC+RC+sSecondLine)
									SINON
										Info("Impossible de récupérer les statstiques : ","request : " + sXMLEXPRESS.envoyersmspro.error.request, "error_id : " + sXMLEXPRESS.envoyersmspro.error.error_id, "error_message : " +  sXMLEXPRESS.envoyersmspro.error.error_message)
									FIN		
								SINON
									Erreur(ErreurInfo())
								FIN				      			
				      			sENVOYERSMSPRO_LOGIN est une chaîne
								sENVOYERSMSPRO_LOGIN=""
								
								sENVOYERSMSPRO_PASSWORD est une chaîne
								sENVOYERSMSPRO_PASSWORD=""
								
								sUrlRequete est une chaîne
								sUrlRequete ="https://www.envoyersmspro.com/api/message/cancel"
								
								// Paramètres Post
								sParametrePost est une chaîne
								sParametrePost=ChaîneConstruit("messageid=%1","759560")
								
								// Requête
								SI HTTPRequête(sUrlRequete, "", "",sParametrePost, "application/x-www-form-urlencoded",sENVOYERSMSPRO_LOGIN,sENVOYERSMSPRO_PASSWORD)=Vrai ALORS
									sXMLEXPRESS est un xmlDocument
									sXMLEXPRESS = XMLOuvre(HTTPDonneRésultat(httpRésultat),depuisChaîne)
									SI sXMLEXPRESS.envoyersmspro.status = "success" ALORS
										
										sFirstLine est une chaîne
										sFirstLine = "Votre envoi a bien été annulé : "
										
										sFirstLine += RC + RC + "Le messageid : " + sXMLEXPRESS.envoyersmspro.message.message_id
										sFirstLine += RC + sXMLEXPRESS.envoyersmspro.message.recredited_sms + " SMS recrédité"
										sFirstLine += RC + sXMLEXPRESS.envoyersmspro.message.sms_remaining + " SMS restant"
										
										Info(sFirstLine)
									SINON
										Info("Impossible d'annuler l'envoi : ","request : " + sXMLEXPRESS.envoyersmspro.error.request, "error_id : " + sXMLEXPRESS.envoyersmspro.error.error_id, "error_message : " +  sXMLEXPRESS.envoyersmspro.error.error_message)
									FIN		
								SINON
									Erreur(ErreurInfo())
								FIN				      			
				      			sENVOYERSMSPRO_LOGIN est une chaîne
								sENVOYERSMSPRO_LOGIN=""
								
								sENVOYERSMSPRO_PASSWORD est une chaîne
								sENVOYERSMSPRO_PASSWORD=""
								
								sUrlRequete est une chaîne
								sUrlRequete ="https://www.envoyersmspro.com/api/account/getallaccounts"
								
								// Requête
								SI HTTPRequête(sUrlRequete, "", "","", "",sENVOYERSMSPRO_LOGIN,sENVOYERSMSPRO_PASSWORD)=Vrai ALORS
									
									sXMLEXPRESS est un xmlDocument
									sXMLEXPRESS = XMLOuvre(HTTPDonneRésultat(httpRésultat),depuisChaîne)
									
									SI sXMLEXPRESS.envoyersmspro.status = "success" ALORS
										
										XMLDocument("tmpXML",HTTPDonneRésultat(httpRésultat))
										
										sText est une chaîne
										sText = ""
										
										XMLRecherche("tmpXML", "account", XMLBalise ,XMLExact)
										TANTQUE XMLTrouve("tmpXML") = Vrai
											XMLFils("tmpXML")
											
											sText += RC + RC + "L'accountid :  " + XMLDonnée("tmpXML")
											XMLSuivant("tmpXML")
											sText += RC + "Le nom du compte : " + XMLDonnée("tmpXML")
											XMLSuivant("tmpXML")
											
											sText += RC + "SMS restant : " + XMLDonnée("tmpXML")
											XMLParent("tmpXML")
											XMLSuivant("tmpXML")
										FIN
										
										XMLTermine("tmpXML")
										
										Info("Voici vos comptes : ",sText)
									SINON
										Info("Problème lors de la récupération des comptes : ","request : " + sXMLEXPRESS.envoyersmspro.error.request, "error_id : " + sXMLEXPRESS.envoyersmspro.error.error_id, "error_message : " +  sXMLEXPRESS.envoyersmspro.error.error_message)
									FIN	
								SINON
									Erreur(ErreurInfo())
								FIN				      			
				      			sENVOYERSMSPRO_LOGIN est une chaîne
								sENVOYERSMSPRO_LOGIN=""
								
								sENVOYERSMSPRO_PASSWORD est une chaîne
								sENVOYERSMSPRO_PASSWORD=""
								
								sUrlRequete est une chaîne
								sUrlRequete ="https://www.envoyersmspro.com/api/account/create"
								
								// Paramètres Post
								sParametrePost est une chaîne
								sParametrePost=ChaîneConstruit("accountname=%1","Nouveau compte WINDEV") 
								
								// Requête
								SI HTTPRequête(sUrlRequete, "", "",sParametrePost, "application/x-www-form-urlencoded",sENVOYERSMSPRO_LOGIN,sENVOYERSMSPRO_PASSWORD)=Vrai ALORS
									sXMLEXPRESS est un xmlDocument
									sXMLEXPRESS = XMLOuvre(HTTPDonneRésultat(httpRésultat),depuisChaîne)
									SI sXMLEXPRESS.envoyersmspro.status = "success" ALORS
										Info("Compte créé! " , RC + "Le accountid : " + sXMLEXPRESS.envoyersmspro.account.account_id)
									SINON
										Info("Impossible de créer le compte : ","request : " + sXMLEXPRESS.envoyersmspro.error.request, "error_id : " + sXMLEXPRESS.envoyersmspro.error.error_id, "error_message : " +  sXMLEXPRESS.envoyersmspro.error.error_message)
									FIN		
								SINON
									Erreur(ErreurInfo())
								FIN				      			
				      			sENVOYERSMSPRO_LOGIN est une chaîne
								sENVOYERSMSPRO_LOGIN=""
								
								sENVOYERSMSPRO_PASSWORD est une chaîne
								sENVOYERSMSPRO_PASSWORD=""
								
								sUrlRequete est une chaîne
								sUrlRequete ="https://www.envoyersmspro.com/api/account/delete"
								
								// Paramètres Post
								sParametrePost est une chaîne
								sParametrePost=ChaîneConstruit("deleteaccountid=%1","0") 
								
								// Requête
								SI HTTPRequête(sUrlRequete, "", "",sParametrePost, "application/x-www-form-urlencoded",sENVOYERSMSPRO_LOGIN,sENVOYERSMSPRO_PASSWORD)=Vrai ALORS
									
									sXMLEXPRESS est un xmlDocument
									sXMLEXPRESS = XMLOuvre(HTTPDonneRésultat(httpRésultat),depuisChaîne)
									
									SI sXMLEXPRESS.envoyersmspro.status = "success" ALORS
										
										XMLDocument("tmpXML",HTTPDonneRésultat(httpRésultat))
										
										sText est une chaîne
										sText = ""
										
										XMLRecherche("tmpXML", "account", XMLBalise ,XMLExact)
										TANTQUE XMLTrouve("tmpXML") = Vrai
											XMLFils("tmpXML")
											
											sText += RC + RC + "L'accountid :  " + XMLDonnée("tmpXML")
											XMLSuivant("tmpXML")
											sText += RC + "Le nom du compte : " + XMLDonnée("tmpXML")
											XMLSuivant("tmpXML")
											
											sText += RC + "SMS restant : " + XMLDonnée("tmpXML")
											XMLParent("tmpXML")
											XMLSuivant("tmpXML")
										FIN
										
										XMLTermine("tmpXML")
										
										Info("Compte supprimé ! " + RC + RC + "Voici vos comptes : ",sText)
									SINON
										Info("Problème lors de la suppression du compte : ","request : " + sXMLEXPRESS.envoyersmspro.error.request, "error_id : " + sXMLEXPRESS.envoyersmspro.error.error_id, "error_message : " +  sXMLEXPRESS.envoyersmspro.error.error_message)
									FIN	
								SINON
									Erreur(ErreurInfo())
								FIN				      			
				      			sENVOYERSMSPRO_LOGIN est une chaîne
								sENVOYERSMSPRO_LOGIN=""
								
								sENVOYERSMSPRO_PASSWORD est une chaîne
								sENVOYERSMSPRO_PASSWORD=""
								
								sUrlRequete est une chaîne
								sUrlRequete ="https://www.envoyersmspro.com/api/account/transfer"
								
								// Paramètres Post
								sParametrePost est une chaîne
								sParametrePost=ChaîneConstruit("debitaccountid=%1&creditaccountid=%2&sms=%3","0","0","1") 
								
								// Requête
								SI HTTPRequête(sUrlRequete, "", "",sParametrePost, "application/x-www-form-urlencoded",sENVOYERSMSPRO_LOGIN,sENVOYERSMSPRO_PASSWORD)=Vrai ALORS
									sXMLEXPRESS est un xmlDocument
									sXMLEXPRESS = XMLOuvre(HTTPDonneRésultat(httpRésultat),depuisChaîne)
									SI sXMLEXPRESS.envoyersmspro.status = "success" ALORS
										Info("SMS transférés!" , RC + "Le compte débité :" + RC + RC + "Le accountid : " + sXMLEXPRESS.envoyersmspro.accounts.debitaccount.account_id + RC + "Le nom du compte : " + sXMLEXPRESS.envoyersmspro.accounts.debitaccount.account_name + RC + "SMS restant : " + sXMLEXPRESS.envoyersmspro.accounts.debitaccount.sms_remaining,RC + "Le compte crédité :" + RC + RC +  "Le accountid : " + sXMLEXPRESS.envoyersmspro.accounts.creditaccount.account_id + RC + "Le nom du compte : " + sXMLEXPRESS.envoyersmspro.accounts.creditaccount.account_name + RC + "SMS restant : " + sXMLEXPRESS.envoyersmspro.accounts.creditaccount.sms_remaining)
									SINON
										Info("Impossible de transférer  les SMS : ","request : " + sXMLEXPRESS.envoyersmspro.error.request, "error_id : " + sXMLEXPRESS.envoyersmspro.error.error_id, "error_message : " +  sXMLEXPRESS.envoyersmspro.error.error_message)
									FIN		
								SINON
									Erreur(ErreurInfo())
								FIN				      			
				      			sENVOYERSMSPRO_LOGIN est une chaîne
								sENVOYERSMSPRO_LOGIN=""
								
								sENVOYERSMSPRO_PASSWORD est une chaîne
								sENVOYERSMSPRO_PASSWORD=""
								
								sUrlRequete est une chaîne
								sUrlRequete ="https://www.envoyersmspro.com/api/stopsms/activate"
								
								// Paramètres Post
								sParametrePost est une chaîne
								sParametrePost=ChaîneConstruit("phonenumber=%1","33600000000") 
								
								// Requête
								SI HTTPRequête(sUrlRequete, "", "",sParametrePost, "application/x-www-form-urlencoded",sENVOYERSMSPRO_LOGIN,sENVOYERSMSPRO_PASSWORD)=Vrai ALORS
									sXMLEXPRESS est un xmlDocument
									sXMLEXPRESS = XMLOuvre(HTTPDonneRésultat(httpRésultat),depuisChaîne)
									SI sXMLEXPRESS.envoyersmspro.status = "success" ALORS
										Info("Stop SMS activé pour le " + sXMLEXPRESS.envoyersmspro.stopsms.phone_number)
									SINON
										Info("Impossible d'activer le STOP SMS : ","request : " + sXMLEXPRESS.envoyersmspro.error.request, "error_id : " + sXMLEXPRESS.envoyersmspro.error.error_id, "error_message : " +  sXMLEXPRESS.envoyersmspro.error.error_message)
									FIN		
								SINON
									Erreur(ErreurInfo())
								FIN				      			
				      			sENVOYERSMSPRO_LOGIN est une chaîne
								sENVOYERSMSPRO_LOGIN=""
								
								sENVOYERSMSPRO_PASSWORD est une chaîne
								sENVOYERSMSPRO_PASSWORD=""
								
								sUrlRequete est une chaîne
								sUrlRequete ="http://test.envoyersmspro.com/api/stopsms/deactivate"
								
								// Paramètres Post
								sParametrePost est une chaîne
								sParametrePost=ChaîneConstruit("phonenumber=%1","33600000000") 
								
								// Requête
								SI HTTPRequête(sUrlRequete, "", "",sParametrePost, "application/x-www-form-urlencoded",sENVOYERSMSPRO_LOGIN,sENVOYERSMSPRO_PASSWORD)=Vrai ALORS
									sXMLEXPRESS est un xmlDocument
									sXMLEXPRESS = XMLOuvre(HTTPDonneRésultat(httpRésultat),depuisChaîne)
									SI sXMLEXPRESS.envoyersmspro.status = "success" ALORS
										Info("Stop SMSdés activé pour le " + sXMLEXPRESS.envoyersmspro.stopsms.phone_number)
									SINON
										Info("Impossible de désactiver le STOP SMS : ","request : " + sXMLEXPRESS.envoyersmspro.error.request, "error_id : " + sXMLEXPRESS.envoyersmspro.error.error_id, "error_message : " +  sXMLEXPRESS.envoyersmspro.error.error_message)
									FIN		
								SINON
									Erreur(ErreurInfo())
								FIN				      			

Nos autres langages de programmation

Vos packs SMS

section


Envoi de sms groupé
ou à l'unité


  • Sans engagement
  • Sans date limite d'utilisation
  • Sans frais supplémentaires
  • Des prix dégressifs


500 SMS

7,4 cts/unité
37 € HT
Achetez

1000 SMS

7 cts/unité
70 € HT
Achetez

5 000 SMS

6,7 cts/unité
335 € HT
Achetez

10 000 SMS

6,5 cts/unité
650 € HT
Achetez

50 000 SMS

6,2 cts/unité
3 100 € HT
Achetez

100 000 SMS

6 cts/unité
6 000 € HT
Achetez


A la carte

SMS = - € HT soit -cts/unité